Can't import fonts into asset library

Fill this out this info to make it easier for the community to help you! If you don’t fill out this information, your post may be deleted or removed.

What Wick Editor Version are you using?
1.19 Windows download

Describe the Problem
Can’t import any fonts.
Get an error message.

What have you tried so far?
Using web editor. Also doesn’t work.

There’s a method described in a post to use a Google Font so as to avoid the need to download a font to use it within the web editor, but I use desktop and don’t know how to fix it.

Do you have a Wick Editor File that we can see? Optional*
No. I would screen record, but honestly any trial at screen recording would contain information I don’t know how to remove.


I had the same problem when I tried uploading a font once. it seems that we can only use the built-in fonts.

but there is this…

1 Like

Yeah, I was talking about that post. Then should I turn this into a bug report, or is it unnecessary?

1 Like

to be honest, i’m not sure if it’s a bug or not. there are already those built-in fonts in wick, so maybe we aren’t meant to have other ones.


As I see it, it’s either they tried integrating font import and couldn’t succeed, or never thought about font import at all. I see the first one as more likely. But I doubt they thought about it and decided we shouldn’t be able to use other ones.
Do you know whether the devs are aware font import fails?

1 Like