Audio Export Bug In Version 1.19.3

I have been making an animation in Wick for the first time. Throughout the process, I’ve exported the project in video form multiple times to test it out, but recently, a very specific portion of audio refuses to be exported.

I can confirm it’s not related to the layer, as a different sound later in the same layer gets played perfectly fine, and putting the broken audio on a different layer doesn’t fix it either.

I can also confirm that the sound file itself is not the problem, as deleting and redownloading the sound doesn’t work, but using the sound on a different part of the animation does works.

This bug persists even if I export as a .wav or if I delete every other layer to save memory.

I have no clue what causes the bug or what the specifics of it even are, so I don’t know how to work around it. I’ve seen similar posts detailing similar problems, but no solution. If anyone knows a workaround, I’d be happy to hear it.

UPDATE: After some more testing, I was able to get the export to work properly by transferring the project to a different computer and opening it there. I was using a Mac computer initially and transferred it to a Windows computer.

maybe try saving the project then restarting wick

do you have a wick file to show the problem? not sure what could cause the issue.

if you don’t want to give the entire file you can remove all the other layers and remove everything else other than the sound.

and just asking, if you put a different audio file in the exact same place, will it work?

I tried that a few times, but it didn’t seem to work. Even loading it up in a different version of Wick didn’t fix it.

  1. I would attach the Wick file, but I cannot, since I am a “new user”.

  2. It does not work if I put a different audio file in the same place. However, it’s not just a temporarily mute section, cause the background music still plays as intended throughout the entire animation. I think it might be bugged when the sound starts within a certain window, but I need to test that.

maybe its the type of file you used or the specific file
what file type did you use and is it the same file type as the rest (ex: .mp3 file)

I’m not sure what you mean by this. The saved file I have is a .Wick file and I tried exporting it as a .MP4 and .WAV.

I updated your user level—you should be able to upload now

I mean the file type of the sound that won’t work. check its file type and then check the file type of the rest of the sounds

I can confirm all the file types are the same.

SoundBug.wick (1.8 MB) Oh, great! The normal file is too big too upload, so this is a version with only sound and some visuals to indicate when the sound plays.
Though, I’ve gotten the sound export to work on a different type of computer. Maybe that causes the bug? It probably isn’t processing power, as my main Mac computer is much faster than the Windows computer I transferred it to.

yeah, export seemed fine to me. all i can think of right now is that it’s something with the browser–might be not fully updated or you might not be on chromium or firefox? (i’m on a mac as well so not sure what else it can be)

I did a test comparing before I updated my browser and after, but it didn’t make a difference. I’m using Google Chrome. I could maybe try using a different browser, but I dunno why that’d be the problem, considering I was using Chrome on my other computer as well.

UPDATE: Welp, using Safari didn’t work.

Okay, new update, the windows computer is not entirely foolproof after all. I’ve worked on the animation more, and now, a different sound is gone, specifically the music. And the original missing sound exports just fine now.