Tweening opacity?


I’m trying to get tweening (tweening of movement much improved - thanks!) to work for opacity of an object, but what ever I try, it will not tween this. Is this a know / non solved bug, or has anybody found a way to do this?



1 Like

I tried doing a quick tween animation with opacity and it seemed to work for me. Here’s the file I made:
tweenopacity.wick (1.8 KB)

well, obviously I’m missing something here :frowning:
I select the item, make a tween on the frame, select the end frame, and drag the opacity to 0…
But the opacity keeps jumping back :woozy_face:
Can you describe what you did? :pleading_face:

I did a few experiments, and I think maybe it has to do with the slider glitching? When you’re on the end frame, instead of using the slider to change opacity, type 0 in the box next to opacity instead. Let me know if that works. On a side note, I can’t really remember if that’s what I did before, but that’s the only thing I can think of. :woozy_face:

ROFL… well, you made a tween in a clip; I tried to do it in the main timeline. That is /a/ difference, but I do not think it should be an important one. It should work in the main timeline as well?
I tried in a clip (I’m not familiair working with clips…) and the 3d time it did work.
But it is wonkey as hell for me :sob:
Which is strange; it used to work, 2 or 3 versions back…


I don’t think it being a clip vs main timeline animation would matter in this case. It’s definitely a very inconsistent sort of glitch, which makes it hard to isolate a cause (or solution) …I can say that what seemed to work for me the most was to drag the slider to 0, and then also type in 0 in the box (even if it already says 0). Odd, but I guess when giving it two inputs, it has to accept at least one of them? :woozy_face:

Hi @bluecake,

thanks to your remarks, I got it working :slight_smile:
You, indeed, need to:

  1. use the slider to set it to 0
  2. enter the number field, retype 0, press
  3. click on the canvas, not the object

If I follow these steps, it works 100% of the time.
If i do not, strange things happen in the universe… :alien:



Good to know that there’s a solution, even if it’s a bit…er, roundabout? :sweat_smile:

I can confirm this bug. My “roundabout” was making separate frames, and changing the opacity manually. Not a good solution, but in my case okayish, since the number of frames was relatively small…

That’s the same way I did it!