Why is wick stuck on exporting my animation as a gif?

Hi! So I just finished making a tweening animation yesterday, it took me a couple of hours and was really happy with the finished product. When I tried to export is as a gif, all would run smoothly, but when the loading bar reached the end (Rendered 359/359 frames), nothing would happen. I tried it again today on my laptop, specifically a chromebook. I’ve been waiting around 30 minutes now, probably longer, and it’s doing the same thing of rendering all the frames but not actually doing anything after that. I’m very new to wick, this is the second animation i’ve actually made on here so I’m not sure if this is normal or if it’s a bug.
Here’s a screenshot of what wick has been looking like for the past 30-or-so minutes: https://cdn.discordapp.com/attachments/616921168850583552/711013310970986566/7wAAAAASUVORK5CYII.png

Hi @frustleyy welcome to Wick forums!
:wave:

Exporting that gif might’ve been tough, I would recommend trying to export it on https://test.wickeditor.com/
:point_up_2:
Your work is great by the way!
:+1:
Hope it works, keep up the progress!
:fist_right: :fist_left: