ZIP file confusion

#1

I’m a bit confused. I have this project that is about a button that changes its location when you click on it. I saved it to a .zip file on a MacBook Air on Google Chrome, and I don’t know how to open it and be able to open it on Chrome again on a new tab so I can play with it, but not on the editor.

My Project.wick (3.5 KB)

0 Likes

#2

Inside the .zip file (which is a compressed folder) is a file called “index.html”. Drag and drop that into a new tab in Chrome, that should open it :slight_smile:

1 Like

#3

it doesnt work. it becomes this giant wick logo that covers the page

0 Likes

#4

Just tried it out, looks like you’re right. Projects from the live editor can be opened just fine using the method I mentioned above, but I tried opening a few projects from the alpha editor and I’m getting stuck on the preloader as well. This is showing up in the console:
ErrorsInConsole

Any thoughts, @Luxapodular ?

Interestingly, I uploaded one of the projects that failed to open in Chrome to an unpublished project on Newgrounds, and everything worked just fine.

1 Like

#5

yeah. thanks for trying to help though!

0 Likes

#6

The big problem with opening the html files has to do with the same origin policy.

You’ll notice that when you open an html file in most browsers, the URL will look something like this:

file:///Users/zrispo/Desktop/MyProject/index.html

Notice how the URL begins with “file:” instead of “http:” or “https”. In Chrome, I believe what’s happening is there’s some extra security that has to do with the same-origin policy - any file accessed using “file:” and not “http” is treated as if it were coming from a different website, so the preloader gets stuck while trying to load the engine and the wick project.

In Firefox, it looks like they don’t have this extra security measure, so opening the HTML file inside the zip works fine, so using Firefox to test your projects is a workaround for now.

2 Likes

#7

Also - once your .zip file is posted to somewhere like Newgrounds or itch.io, these security rules don’t apply since all files will load from the same website, and they project should load fine.

Me and @Luxapodular are still trying to find a fix for this, will update everyone when we do!

2 Likes

#8

Opening in Firefox works for my projects just fine. That’ll do.

0 Likes

#9

ok, thank you!

0 Likes