Pixel Lide (Pixel art/ animations!)

New update: Pixel Lide 0.03

Projects can be saved and shared!

You can load autosave, use a project code, or delete autosave!

You can also now have share links!

You can click the little yellow “!” button to get the option to clear project, get the project’s save code, get the project’s share link, or speak with Blob!

Click “Link” to get the project’s link.
You can copy the share link by clicking ctrl+c or right click the text, and click copy!

This update took long, but now your project can be translated to a code and re-translated to a project!

I still need testers though… so I would appreciate it if you guys play around with this a bit.

I have noticed that the project started working slower after this update.

Sample project link: A project with text saying “PIXEL LIDE”
Also, I just noticed there’s a bug when getting every pixel’s correct color

<-- Original project <-- Loaded code
Colors are getting switched up


how do I get in?

I’m not sure what you’re talking about (get in what?)
If you mean the project, here’s the link: https://pixel.lide.repl.co/

I’m pretty bad at it, but it is nice! (The link feature broke for me, not sure why)


I love it!!!

1 Like

Nice, that looks amazing :D

Yes, I realized there’s a couple of bugs when trying to retrieve a project.
The pixel colors get mixed up. I’ll try to see what’s causing this issue, and hopefully get it fixed soon.

1 Like

I mean I cant get in if I press something it all slows to a halt

Can you upload the wick file? I’ve been experimenting with ways to improve performance such as obfuscation and Pixel Lide would be a great program to test them on.
Also, you could use lz-string (https://pieroxy.net/blog/pages/lz-string/demo.html) to compress links and code.

Sure, here’s the Wick file for Pixel Lide 0.04:
New Pixel Animator3-20-2021_15-17-04.wick (139.8 KB)

Some things in the file (such as the share link and about button) won’t work in the editor.
Also, make sure that the layer named “Pixels” is focused on before starting the project

(How the project works is that it creates an actual frame in the editor for every frame created, and stores info of all the arrays in an array called project.CloneArray. The other two arrays (project.PosXY_Data and project.All_Pixels) don’t do anything, I’m trying to use them for something else)


New Pixel Animator3-20-2021_15-44-03.html (2.3 MB)
Here it is but the loading cursor comes up. You can still place and use it normally though

There seems to be a problem with the file.

Also, I just noticed that when deleting autosave, the project stops working
(This is probably because the saved data is null)

1 Like

in the wick file when I click load save after a few seconds it gives me an error

Thanks for letting me know, can you test this version and see if the same error is there?
html (2.3 MB) wick (139.8 KB)

1 Like

it still happens

1 Like

I agree, onion skinning is a really important tool when it comes to animating!

I will try my best to hopefully add this feature in… 2 weeks? It’s more likely to take longer though


Like the new pfp!

1 Like

Thnx, I made it just now with Wick
Lide Logo_3-21-2021_18-43-57


I didn’t find the bug where the color doesn’t load properly from the save code, but I did fix that bug by using a different method.

Autosave is now more accurate with color

Note: I didn’t update the link yet because the project runs REALLY SLOW when it loads the autosave (lemme know if you wanna try the html file). Also, the “enter code” feature is broken.

But here’s a test I did:

I pixelated something with a lotta random colors

Then I tried reloading tab and loading the project:


I tried making something https://pixel.lide.repl.co/?3//332,141,{red:0,green:0,blue:0},1,1;345,141,{red:0,green:0,blue:0},1,1;358,141,{red:0,green:0,blue:0},1,1;371,141,{red:0,green:0,blue:0},1,1;383,141,{red:0,green:0,blue:0},1,1;396,141,{red:0,green:0,blue:0},1,1;409,153,{red:0,green:0,blue:0},1,1;422,166,{red:0,green:0,blue:0},1,1;422,179,{red:0,green:0,blue:0},1,1;422,192,{red:0,green:0,blue:0},1,1;422,205,{red:0,green:0,blue:0},1,1;422,217,{red:0,green:0,blue:0},1,1;422,230,{red:0,green:0,blue:0},1,1;409,243,{red:0,green:0,blue:0},1,1;396,243,{red:0,green:0,blue:0},1,1;383,243,{red:0,green:0,blue:0},1,1;371,243,{red:0,green:0,blue:0},1,1;345,243,{red:0,green:0,blue:0},1,1;358,243,{red:0,green:0,blue:0},1,1;332,243,{red:0,green:0,blue:0},1,1;320,230,{red:0,green:0,blue:0},1,1;320,217,{red:0,green:0,blue:0},1,1;320,205,{red:0,green:0,blue:0},1,1;320,192,{red:0,green:0,blue:0},1,1;320,179,{red:0,green:0,blue:0},1,1;320,166,{red:0,green:0,blue:0},1,1;320,153,{red:0,green:0,blue:0},1,1;422,153,{red:0,green:0,…71,230,{red:1,green:1,blue:1},3,0.4;371,243,{red:1,green:1,blue:1},3,0.4;371,281,{red:1,green:1,blue:1},3,0.4;371,294,{red:1,green:1,blue:1},3,0.4;371,307,{red:1,green:1,blue:1},3,0.4;358,141,{red:1,green:1,blue:1},3,0.4;409,128,{red:1,green:1,blue:1},3,0.4;422,141,{red:1,green:1,blue:1},3,0.4;435,141,{red:1,green:1,blue:1},3,0.4;447,141,{red:1,green:1,blue:1},3,0.4;460,141,{red:1,green:1,blue:1},3,0.4;473,141,{red:1,green:1,blue:1},3,0.4;486,141,{red:1,green:1,blue:1},3,0.4;498,141,{red:1,green:1,blue:1},3,0.4;511,141,{red:1,green:1,blue:1},3,0.4;524,141,{red:1,green:1,blue:1},3,0.4;537,141,{red:1,green:1,blue:1},3,0.4;550,153,{red:1,green:1,blue:1},3,0.4;562,153,{red:1,green:1,blue:1},3,0.4;575,153,{red:1,green:1,blue:1},3,0.4;575,166,{red:1,green:1,blue:1},3,0.4;588,179,{red:1,green:1,blue:1},3,0.4;562,230,{red:1,green:1,blue:1},3,0.4;486,307,{red:1,green:1,blue:1},3,0.4;447,332,{red:1,green:1,blue:1},3,0.4;435,345,{red:1,green:1,blue:1},3,0.4;422,358,{red:1,green:1,blue:1},3,0.4;

Thanks for sharing @BSA_15, this helped me find the error with loading projects.
I thought the issue was in running the code, but the issue was actually in the code :exploding_head:

I corrected the code that the project saves, however, the project keeps on giving the user a code that doesn’t work. For example:
Correct link
Incorrect link

From now until I crush this bug, here's how to get an accurate link/ code for your project:
  1. Click ctrl+[
  2. Type this:
prompt("Save code: ",window.localStorage.getItem("save")); prompt("And a Link: ",window.location+"?"+window.localStorage.getItem("save"))
  1. Copy save code or link

Overall updates:

I’m hoping to get started on onion skinning after