Post-Jam Feedback: Misc. Bugs

#1

Here are a bunch of bug reports that I found over the past month or so but haven’t posted yet. I’ve tested most of these to make sure they still happen on the current alpha editor (1.0.13); however, some may be outdated, since I first wrote them down after using versions 1.0.10 through 1.0.12. I’ve tried to eliminate ones that I know have already been seen or fixed.

Anyway, hope this is useful! :bug:

Major Bugs

  • Sometimes download of .wick fails on Firefox. Sometimes I save a file then refresh, not noticing the download has failed, then later my only option is to restore from an out-of-date autosave. Can Wick detect this and warn you?

    • Downloads haven’t failed lately. Maybe this has been fixed :smile:
  • If a clone causes an error, it is not completely deleted when the project stops running. In this example file, a clone that was generated at runtime is still selected when the project stops. BugReport_PlayError.wick (434.1 KB) (Go to frame 2 and play. Click on a letter button to cause the error.)

  • Clear setInterval() loops (as well as setTimeout()) when done testing. (This might be fixed already, I’m not sure) :man_shrugging: (https://psychogoldfish.newgrounds.com/news/post/1054092)

  • Clip position differs between code and inspector. The inspector seems to tell you the top-left of the bounding box, but code gives you the location of the registration point. BugReport_PositionAintRight.wick (1.4 KB)

  • BugReport_GotoOrderOfOps.wick (1.5 KB)
    Say you have a Clip with two frames, each containing a text object, and it is currently stopped on frame 1. Running this code would not work:

    Clip.stop();
    Clip.gotoAndStop(2);
    Clip.text.setText("Hi!");
    
    • gotoAndStop(2) apparently does not run until the next frame or the end of this frame, so Clip.text from frame 1 would get set first. But then the frame changes to show a different text object, so the message doesn’t appear to change. (I’ve reported a similar issue here.)
  • gotoAndStop() and gotoAndPlay() can be used with out-of-range frames. gotoAndStop() is especially dangerous in this regard, because if you put the root timeline to a frame that doesn’t exist, it effectively freezes the project with a blank screen.

  • In an older version (.12, maybe?), I ran into a bug that caused one of my Clip’s frames to be deleted. I can’t reproduce it, though. I have a vague idea of what I did:

    • Extend frame a lot
    • Click underneath the layer in the blank space
    • Huh? Frame disappears, replaced by a blank frame 2
    • Maybe it has to be inside a Clip.
    • I also usually kept my browser zoom at 80% or 90%, resulting in a slightly glitchy-looking timeline (see below).
  • Undoing a script edit while the script editor is closed silently deletes your work! To make this happen, type something in a script, close the script editor, select another object (to trick the undo system), and then hit Ctrl-Z multiple times. Bring the script back up and your new code will be gone.

    • Instead, pressing Ctrl-Z after closing the script editor should bring it back up and select the last code you changed. Press it again to undo this code.

Minor Bugs

  • Dynamic text wraps differently from static text and has different line spacing
    image

    • In general, graphical issues like this probably won’t happen in the next version since pixi.js was removed, but I wanted to report this anyway.
  • Changing browser zoom while editor is running sometimes causes paths/Clips to render at the wrong size and position during play mode. (Usually too big, and offset to the bottom-right.) Refreshing fixes the issue while maintaining your chosen zoom level.

  • Trying to double click to exit a Clip while a locked layer is selected gives a “trying to edit locked layer” error.

  • “Ctrl+C” and “Ctrl+V” to Copy and Paste frames doesn’t always work. I find that I often have to click the stage and then click the timeline before it will work.

  • Text can be skewed by rotating it then scaling it (because the bounding box resets) but this doesn’t apply when running project
    image

    • The bounding box shouldn’t reset like that, but skewing objects is still a very useful feature and should be kept. :smile:
  • You can’t send a text object in front of or behind another text object.

  • Error tooltips spawn at wrong position. (My mouse is on the top red [x] icon.)

    • If the scripting window is too close to the bottom-right, the tooltip will not be visible at all.
  • Pressing ` to toggle the script editor 3 times in a row fails the third time if an object or frame is selected. There is also some lag before it comes up.

  • Can’t manually type in shape opacity (example: 0.3), as the field removes all periods. If I type really fast and press enter, I can sneak it in, though, and it will work.

  • In Flash, while editing a symbol, you double-click the background to exit. Wick has a similar behavior, except selecting one of the objects inside the Clip can count as one of the clicks. This means if you do either of the following, you will unintentionally exit the Clip.

    • double-click a path
    • click an object and then click the background shortly after
  • Maybe there should also be a very short grace period (like half a second) after you enter a click where “double-click to exit” doesn’t work. This prevents you from entering a Clip and accidentally exiting it immediately.

  • When tweening a clip, sometimes trying to select the Clip after selecting the timeline doesn’t work, even if the playhead is at a tween keyframe.

  • Tween keyframe highlights often stay in after you deselect it.

  • Brush cuts off when drawing a stroke that extends outside the visible area. Sometimes the area the brush will draw in gets misaligned with the view. Brush%20area%20bug

  • Right-hand side of Timeline is bugged if you start Wick with the browser is zoomed out (Firefox)
    image

  • “Delete script” brings the script editor up in front of the Delete panel.

2 Likes

#2

Good stuff, a few of these were fixed in the new prerelease version!

Will be working on the rest this week~

2 Likes

#3

Forgot to report this bug:

Tween%20Out-of-range%20Bug

It happens in both 1.0.14pre and in older versions.

1 Like

#4

We were just talking about this bug this morning. We should have it fixed next update!

2 Likes

#5

I’d like to add on to this post if I may.
So I have a few issues with Wick atm unfortunately…
I’m not sure if this should be it’s own separate post or not, but
here we go! :upside_down_face:

So I primarly use the legacy editor because it has a more
“comfortable” feel to it imo.
But, as many are probably aware, it has quite a few bugs in it, and it
of course isn’t updated anymore. I’ve continued to use it for
many reasons, such as the more pleasing UI, the better designed
code editor, how quick it is, etc… There’s just a lot of things that I personally love about it.
:stuck_out_tongue_winking_eye:

Anyway, I’ve run into a problem that I simply can’t get around.
It seems that if a project gets kind of big, (nothing major, just around 1-2 mb) running it for a while will gradually cause it to slow down until it’s made unplayable. I’ve tested it with multiple projects, and even exporting them and running them in other environments besides Wick, but the slow down always happens… I figured I could maybe use the project converter and try and port my project to the Wick alpha, but unfortunately there’s two things wrong with that also.

First:
The Alpha Editor itself runs very slowly on my device.
I don’t believe I could manage to get anything done with how slow it is.
(It’s hair pulling slow. :joy:)
The Legacy editor on it’s own however works fine, aside from actually playing
projects for a while, which is when slowdown occurs.

Second:
The project converter doesn’t work all that well.
It completely deleted one of my constructors, and rendered my game unplayable.
A quick example of what happened:

-The original-
function Constru(x,y,data){
this.x =x;
this.y =y;
this.data =data;
}

-After being converted-
{
this.x =x;
this.y =y;
this.data =data;

}

Doing this caused a bunch of undefineds and other errors. :frowning:
I was able to clear up all the errors, but it still had a bunch of problems
undetected by the bug checker, and didn’t play correctly.
Basically, you can’t easily port a project from Legacy to Alpha,
which is another let down, as I was hoping the Alpha would run things a lot more
smoothly.

So for now, I’m not sure what I should do.
I really love the editor, but I can’t get even small projects off the ground currently.
Should I wait until the Alpha is more polished, or could their perhaps be something I’m
doing wrong?

Anyway, just something I wanted to post, and if you read this all, thanks!
:slight_smile:

P.S:
Oh, and if anyone would like to see what I mean by the slowdown, I could try to screen record it.

1 Like

Maximum Workload
#6

The alpha editor isn’t usually hair-pulling slow for me, but I have noticed some lag. For example, bringing up the script editor and switching tools has a small but noticeable delay.

Are you cloning a bunch of objects in your project? That has lead to massive editor lag for me since the clones probably aren’t cleaned up when the project stops.

If you decide to record your screen, ScreentoGIF (Windows only) and OBS (all platforms) are good choices.

edit: Also, what kind of browser, OS, and CPU are you running?

1 Like

#7

First off, thanks for reading! :slight_smile:

Saw the edit, so:
Browser-Firefox developer edition,
OS-Windows 10,
Cpu-(I’m not an expert so I assume you mean this? Correct me if I’m wrong!)
Intel® Atom™ CPU Z3735F @ 1.33GHz 1.83 GHz.
I’m using an Azpen Tablet.

The Alpha is very slow while the Legacy is not at all.

Yes, I’m constantly creating clones. Could that be it?
Again I’m using the Legacy editor. Is it a known problem?

I have screen to gif after your recommendation a few weeks ago.
(Thanks again for that!)

1 Like

#8

Hey @colorsCrimsonTears, We’ll look into some of these issues you’re having. If you send me you project in a PM I can try to add a bugfix to the project converter!

Have you tried using the text branch on test.wickeditor.com? This update did add a few performance improvements which might help!

We are slowly chipping away at these slow downs in the alpha editor, so if you have a small demo project you could send us that slows down on your device, send it our way!

Hopefully we can get to the bottom of this soon.

2 Likes

#9

I’ll definitely send it when I can get back to my other device!

I haven’t tried it yet, but I’ll give it a go before sending the project over.
I hope it can be fixed, because I honestly have no idea were the slow down is coming from, and it has me frozen in my tracks!
:joy:
I don’t know if it’s me making the error or Wick.

0 Likes

#10

Bug Report


So, I was getting ready to test my game in the Alpha before sending it over. (Just in case the problems would be fixed and I didn't need to waste anyone's time) :sweat_smile: But I ran into this bug which needs to be checked out! (This was done in the pre-release)

So, if you pick the brush, draw around a bit, (kind of quickly) then afterwards
hit ctrl+a (select all) then delete, (via del key) not all of your strokes will actually be erased, and you’ll be left with an un-eraseable blob of paint.
Attempting to use the brush after this will make it draw with that un-eraseable blob, creating a really funky looking pattern, which causes mega slow down.

Video below.



I wasn’t sure if this should’ve been a separate post or not,
if it should’ve been let me know. :upside_down_face:

I’ll be back with news on how the game converted soon.

0 Likes

#11

So I’m back.
A few of the problems I noticed off the bat are:

The converter deletes any un-nested comments.

I said this earlier, but it removes the function and parameter portion of
constructors.

And lastly with the new code tab system in place, nothing works off the bat unless
you port code manually from the default tab into whatever respective tab it should be in now.
(Like you’d have to manually move your update function into a new update tab.)

Anyway, I’ll pm now and let the pros get to work.
:slight_smile:

0 Likes