Is there a way to put your own font

Im am new to wick editor and i want put my own font

hmm…as far as i know from the wick forms …
you wont able to import your font to wick

but you can add font from Google fonts
this what a tutorial from bluecake

oh and i took this information from

i want add this fontmojang (1).zip (9.9 KB)

Hello @Rand546,

Yes! You can add your own font…
As long as the font format is a .tff (Wick Editor only supports .tff fonts) you’re in luck!
If your font is a .svg or .otf then you’ll have to convert it to a .tff
Here’s some sites that can do that for you…:
OTF to TTF (, SVG to TTF
Hope this helps.

Just in case you didn’t know how to use fonts, first you have to Drag and Drop the font file or upload it to wick editor…

Then you have to select the Text Tool (of course) and create a text.

After that, select the text you created.
Then on the Inspector tab select Font Family, then select the font desired :slight_smile:


plz send me project

i tried doing what you said and it wont work

When I do it says importing files it goes away and I can’t select anything.

when I try with drag-and-drop, it never uploads. when I try importing using the button, it immediately tells me I am not allowed to upload a ttf file.

so I have no idea how you did it… but congrats either way…

I’m sure we could hack wick (it’s open-source so we can remix it and do whatever) to make it allow ttf files… maybe, idk.

Hm that’s odd :thinking:, @MrDashell, @awc95014, @Rand546

Did you reformat the files right? If for example the original file format is a .otf you should convert It online or by using software i.e.:

Also be sure to Import the right file not the folder or text files ect.

If you “converted” it by renaming the file
It is not properly converted or It’s not converted at all!
The contents of the .otf file will not be changed, It’s just simply renaming the file and
It only changes which programs the computer chooses to use to read the file.
Here are files I converted and renamed to .tff: (87.5 KB).
Import one of them to wick editor and see the results…

Hope this helps! :grin:

but the ones I downloaded were .ttf

1 Like

Hm, It’s probably corrupted in some way :thinking:
If other fonts don’t work then that can be probably related to what wick editor version you’re using or a bug, I’m not completely sure…

im on verison 1.19.3

i tried importing your ttf file but this happened

this is what happens when i tried to import my font

1 Like

As I explained the renamed version won’t work, Use the other font file

CosmicKnight, I’ve never had font import work. Tried both OTFs and TTFs. They just… don’t work. Wick doesn’t import fonts well, and only the web editor will let you run fonts on the google fonts library. That’s it.

i did and showed that

I’m sorry but the error is clearly visible from the screenshot you shared.
That file won’t work as i said…
try the other file (without the (renamed) on the file name)

Strange… I’m not sure why but it works just fine when I try to import it. :thinking:
I’ve tested some fonts just to make sure I’m not day dreaming and it seems to work fine.
Here are the files i downloaded: (67.3 KB)
If it still doesn’t work then I guess it’s my operating system. (linux)
But operating system doesn’t seem to have a good connection with fonts on the web tho so I think it’s something else :thinking:

1 Like

The same problem is on Chrome OS, so it’s probably not your OS.